Connectivity issue for some users
Resolved
Jul 30 at 11:14pm BST
Microsoft have advised that the incident was fully resolved on their side as of 21:48 BST. We are likewise declaring this incident closed.
We will continue to engage with Microsoft to understand how a repeat of this situation can be avoided.
Affected services
Updated
Jul 30 at 08:44pm BST
Microsoft have advised that as of 21:00 BST the issue is fully mitigated for APAC and Europe, with the Americas due to be resolved by 21:30 BST. However, we are still receiving isolated reports of ongoing difficulty connecting to sites so we are not yet convinced this is fully resolved and will continue to monitor.
Affected services
Updated
Jul 30 at 06:15pm BST
Microsoft are still experiencing occasional reports of ongoing issues and are therefore continuing to investigate and monitor. As we cannot rule out some customers still having difficulties as a result of this, we will continue to keep this incident active and monitor until we are confident there is no further risk of disruption.
Affected services
Updated
Jul 30 at 05:15pm BST
There is no further update from Microsoft, we continue to monitor and will mark this incident as resolved once we have absolute confirmation from them.
Affected services
Updated
Jul 30 at 04:15pm BST
The situation has remained stable over the last hour; Microsoft has confirmed they have mitigated the issue on their side and continue to monitor to ensure a full recovery.
We likewise continue to monitor ourselves.
Affected services
Updated
Jul 30 at 03:04pm BST
Whilst Microsoft have not yet provided any indication that this issue is resolved, from our own monitoring we are seeing connectivity issues reduce in number and believe that we might be close to the end of this incident.
We will continue to monitor further and will update again once we are confident the issue is resolved.
Affected services
Updated
Jul 30 at 02:02pm BST
Microsoft has confirmed that the issue is global, affecting all their regions. This means that our standard failover approach is unfortunately unable to mitigate this issue as standby regions are affected by the same problem as primary regions.
We are continuing to investigate and explore potential mitigations.
Affected services
Created
Jul 30 at 01:05pm BST
Our infrastructure provider, Microsoft Azure, is currently experiencing a major outage affecting multiple regions. This has resulted in Centrik being inaccessible for many users. The issue is location-dependent, and only affects some users.
We are investigating this issue and exploring potential workarounds, and will provide a further update within the next half hour.
Affected services