Back to overview
Degraded

Connectivity issue for some UK users

Sep 25 at 03:23pm BST
Affected services
Europe, Middle East & Africa

Resolved
Sep 25 at 04:57pm BST

Microsoft have confirmed the issue has been mitigated. All services have returned to normal.

Updated
Sep 25 at 04:12pm BST

Microsoft have not provided any further updates, however from our own monitoring the issue appears to be resolved on their side, and has been stable for the last 15-20 minutes so we believe the incident is now over. We will continue to monitor until Microsoft confirm this from their end.

Updated
Sep 25 at 03:43pm BST

Microsoft have confirmed that they are experiencing an issue with a specific UK region and are investigating. We are exploring options to mitigate on our side. We will update as soon as more information becomes available.

As a temporary workaround, please try using alternative internet connections if possible, such as mobile hotspots or VPNs - this issue is limited to certain internet providers who cannot currently connect to Microsoft services, the Centrik environments themselves are operating as normal.

Created
Sep 25 at 03:23pm BST

We are currently experiencing connectivity issues for some users in the UK due to an upstream problem with our infrastructure provider. We are investigating the situation with them as a matter of urgency and will provide a further update within the next half hour.