Back to overview
Degraded

Intermittent issues for some UK clients

Oct 08 at 10:21am BST
Affected services
Europe, Middle East & Africa

Resolved
Oct 08 at 12:25pm BST

Issue has been identified and resolved.
All centrik systems have returned to normal.

Created
Oct 08 at 10:21am BST

We are experiencing issues with one of our UK based customer groups.
We are currently implementing a workaround while we continue to investigate the issue.